General Help Questions and Answers

Moderators: L|B, cryoa, Riamus, XMog


Postby jackinbox » Sat Dec 27, 2014 11:02 pm

I know there was topics under this already, but i am at a loss here, i have been out of the IRC for a long time, and no have rejoined and i have installed invision perfectly,
i have read every help file and search on google for this and im still at a loss, i have tried every single diff and still cannot get the dcc to work tryiing to share files.
i have spent hours in the DIR-645 router porting and port triggers and setting the svc to run 24/7 i have changed and or added in windows firewall, disabled firewall, and even added my ip to DMZ. i am at a loss here and i have never had this many issues try to do ports. hosting games etc and even private svr games/web server, but this im at a loss if anyone can help please i would like to get back to sharing within the community!
Posts: 1
Joined: Sat Dec 27, 2014 5:53 pm


Postby XMog » Sun Dec 28, 2014 8:48 am

There's probably not too much advice I can give that you haven't already tried. is a popular site for port forwarding for various routers. They have a program that lets you test if the ports are forwarded properly, but there are also sites that don't require an installation, and can test your open ports through the website itself. This would help narrow down if the problem is with the port forwarding, or with mIRC.

You probably know, but DCC works "backwards" compared to normal file transferring. When you are sending a file, the remote party makes a connection to you, and the transfer starts. So, ignoring the unlikely case that the remote party is blocking OUTBOUND connections, most of the work will have to be done by you, the server/sender.

The basic steps are as follows:

- In mIRC Options (Alt+O), go to Connect -> Local. Make sure your host name and IP address are correct. It is recommended you check the "On connect, always get Host Name", with Lookup method set to "Server". This needs to be correct for DCC sending to work.

- In mIRC Options, go to Connect, Options, "Ports" button. Note that this is in a different location in older versions of mIRC. Make sure "DCC Send/get/chat connections" is checked. Set the port range to a semi-small range, preferably in the 10000-65535 range. For example, 43000-43015. You will need one port for each simultaneous file send you plan to have, plus more for each fserve slot (if you will be using the fserve, or any DCC chat windows), plus a small buffer. So, if you allow 5 simultaneous sends, and allow 4 people to be on your fserve at the same time, a 10-12 port range would be sufficient. Make a note of the port range you chose.

- In mIRC Options, go to DCC, Options. Make sure the "Passive DCC" option is NOT checked.

- In mIRC, go into the Invision menu, and choose DCC Manager. Click the "Setup" tab, and make sure "Global Reverse DCC Init" is NOT checked. It should not be checked by default, but this is just to make sure.

- Go into your router ( or whatever IP your router is at), go to the port forwarding section. Don't bother with port triggers, just do standard port forwarding. The specific steps depend on how your router's config pages are set up, but basically you want to forward the port range you set in mIRC's options (43000-43015 in my example) to your computer's local IP (usually something between, available from running IPCONFIG from a command prompt) I assume you already know most or all of this, but this is just in case...

- Optionally reboot your router. Most routers should apply the changes immediately, but it's possible some only apply the changes after the router is rebooted.

- Go into your firewall program. Some antivirus programs have firewalls built into them, so check your antivirus as well to make sure it's not blocking inbound connections. If you are sure no other program is acting as a firewall, go into the Windows Firewall and disable it. Normally you will want this running and just make an exception for mIRC, but just for testing, have it disabled to make sure that it's not the problem. Remember to re-enable it once you're done testing.

- You should now be able to send files in mIRC/Invision. There are certain networks that block certain file transfers, or require a "/dccallow" command entered by the person requesting the file, but these are not common at all. There is also the unlikely possibility that your ISP or something else inbetween is blocking the inbound connection.

If you are STILL having issues, there is not much more I can suggest. You can also visit #Invision on irc.irchighway.net for more direct conversation. Note that we are a small group, so you might have to stick around a little bit for a response.

Global Moderator
Global Moderator
Posts: 44
Joined: Sun Dec 29, 2002 1:49 am

Return to General Help

Who is online

Users browsing this forum: No registered users and 3 guests